YouTube Thumbnail Preview Image

This thread may refer to an older version of JW Player! Check our articles for the most up-to-date information.
This Q&A thread was imported from our previous system and could apply to an older product.
  • Hello

    Thank you for making a wonderful open source product. I love it!

    Is there a way to specify/turn on a preview image for a YouTube video in the mixed media flash player?

    I want my YouTube video to have a preview image (without having to create one manually).

    I want to add it to my page www.deltadreams.com

    Thank you.

  • <track>
    <creator>surfriderfoundation</creator>
    <title>Sand Sculpture</title>
    <location>http://www.youtube.com/watch?v=EqWRZrupLrI</location>
    <image>http://img.youtube.com/vi/EqWRZrupLrI/2.jpg</image>
    </track>
    Can you see the image is the same code as the movie?

    Up Down 0 rated
  • Thanks. Anyway we can make the image larger? It becomes pixelated.

    See how it is at www.deltadreams.com

    Thanks.

    Up Down 0 rated
  • bc.. Anyway we can make the image larger? It becomes pixelated.


    You will have to make that request to YouTube, they make the images.

    Up Down 0 rated
  • Can we make the request for Jeroe to add that feature? I mean, YouTube already has a preview image in the display.

    Up Down 0 rated
  • You can try the official YouTube API preview image; instructions here: *http://groups.google.com/group/youtube-api-issues/browse_thread/thread/a6797d2441797105/4646271b6088a21f#4646271b6088a21f*

    You will still get a 130x97 image directly from the official YouTube API: *http://img.youtube.com/vi/EqWRZrupLrI/1.jpg*

    What you are referring to as a preview image, is actually a frame of the video. The JW Player does not have that capability in the current version v3.16.

    Up Down 0 rated
  • Use /0.jpg for a 320x240 image

    Up Down 0 rated
  • Interesting. Perhaps I can extend the preview image functionality a little so the thumbnails in the playlist actually use another PG than the large preview in the display. Hacked into the YouTube API fast enough with the /0.jpg – /1.jpg trick, but it should be more generalized…

     
    Up Down 0 rated
  • Is there away to force JW player to use 0.jpg?

    Up Down 0 rated
  • The current API allows us to use it when manually creating an .xml:
    <track>
    <title>Socom HD</title>
    <location>http://www.youtube.com/watch?v=0YnowiZ18tk</location>
    <creator>r4lph</creator>
    <image>http://img.youtube.com/vi/0YnowiZ18tk/0.jpg</image>
    </track>
    </trackList>

    But when using a youtube playlist or channel the API needs to be altered. Maybe Jeroen can update us on this one.

    Up Down 0 rated
  • 4.2 will pick the /0.jpg image from YouTube feeds…

     
    Up Down 0 rated
  • Hi,

    I cant get JW player to show youtube image.
    In the settings i have this line:

    image:'http://img.youtube.com/vi/@CODE@/0.jpg',@IFS(IMG)@

    Is that correct?

    Regards
    Mads

    Up Down 0 rated
  • Hi Mads,

    Are you using the Joomla Module?

    Up Down 0 rated
  • Hi Zachary,

    I'm using AVR = AllVideos Reloaded for Joomla.

    Regards
    Mads

    Up Down 0 rated

  • In AVR to change to the newer HQ image:

    In the youtubejw Tag, in Player template tweaks: section
    change
    image:'http://i.ytimg.com/vi/@CODE@/default.jpg',@IFS(IMG)@
    to
    image:'http://i.ytimg.com/vi/@CODE@/hqdefault.jpg',@IFS(IMG)@

    That will change from the old 120x90 image
    to the newer 480x360 image.

    This is the same as the 0.jpg image above.

    Up Down 0 rated
  • Hi AVR2,

    Thank you for that, but I can't get the images to display in the player.

    IF I write:
    image:'http://i.ytimg.com/vi/6jSBW0BOPqM/hqdefault.jpg',@IFS(IMG)@ the images thumb for the specific video shows correct up in the player.

    BUT as soon i write this:

    image:'http://i.ytimg.com/vi/@CODE@/hqdefault.jpg',@IFS(IMG)@

    I only get a black screen as thumb. :(

    It seems to @CODE@ insert the whole url and not just the video id from youtube.

    Is there a @XXXXX@ that only insert the video ID from youtube??
    Or what do you think the problem is then?

    Up Down 0 rated

  • Where are you writing this code?
    All you have to do is add 2 characters (hq) in the Player tweaks.

    It works fine for me.

    Up Down 0 rated
  • Hi,

    I am writing it in Player template tweaks in the manage tags/presets in joomla under youtubejw player.

    It wont display the image,only when i shift "@CODE@" with a video id for a known video.

    I can see when i look at the frontend that the address point at :
    image:'http://i.ytimg.com/vi/http://www.youtube.com/watch?v=tSt1d7o7G/hqdefault.jpg

    So i seems that @CODE@ insert the watch address.
    Does anyone have a clue for a solution?

    Up Down 0 rated

  • Did you put something in tag in the article?

    Up Down 0 rated
  • No the tag in article is
    {youtubejw}Youtube link{/youtubejw}

    Anyone that has same problem?

    Or a solution?

    How can i ONLY insert the youtube ID and not the whole adress as @CODE@ does :(



    Up Down 0 rated
  • Closing here.

    Up Down 0 rated
  • Have you found a resolution?

    Up Down 0 rated
  • Hi Zachary,

    Yes I have inserted the whole youtubelink, and found out that i only should insert the ID numers from youtube.

    Now it works :)

    Regards

    Mads

    Up Down 0 rated
  • How can i do popup`s window from thumb? My code in JCE Editor:

    bc.. {youtubejw width="160" height="128" autostart="false"}Md51H5WCAf8{/youtubejw}
    {flv popup="true" divid="mypopup"}Md51H5WCAf8{/flv}
    {avrpopup type="window" id="mypopup"}Click here to show video in a popup window{/avrpopup}.


    Thank`s

    Up Down 0 rated
  • thank you

    Up Down 0 rated
  • I second Hubble. That's what I need to figure out as well.

    Up Down 0 rated
  • We've opened a ticket for this:

    http://developer.longtailvideo.com/trac/ticket/642

    Up Down 0 rated
  • I am using Version 5.3
    Then thumbnails do not show (see bottom of this page)
    http://www.hipipo.com/
    The playlist is specified in this format

    <track>
    <creator>Nick-Nola-ft-Bella -Okai-I-Love-The-Way-Ugandan</creator>
    <location>http://www.youtube.com/watch?v=o-HeqZADQQM</location>
    <title>Nick-Nola-ft-Bella -Okai-I-Love-The-Way-Ugandan</title>
    ?
    <image>
    http://www.hipipo.com/videos/thumbs/Nick-Nola-ft-Bella -Okai-I-Love-The-Way-Ugandan.png
    </image>
    </track>

    What could be wrong

    Up Down 0 rated
  • You need a crossdomain.xml file here – http://www.hipipo.com/crossdomain.xml

    More information – http://www.adobe.com/devnet/articles/crossdomain_policy_file_spec.html

     
    Up Down 0 rated

This QA is closed.

Still don't have JW Player? Get It Here