Jw player "missing plugin" in chrome

This thread may refer to an older version of JW Player! Check our articles for the most up-to-date information.
This Q&A thread was imported from our previous system and could apply to an older product.
  • Hello guys,

    I've already seen a post which treats the same case, but there is no response about how to fix it.

    http://www.longtailvideo.com/support/forums/jw-player/setup-issues-and-embedding/12407/chrome-browser-doesnt-support-jw-player

    I'm getting Missing Plug-in in chrome (v 16.0.912.63 m)
    It works fine untill the last week.
    Is there any solution for this issue ?

    here an example : http://lkvideos.com/view/34852/isiwara-ranakeli-29-15122011/

    Thank you very much

  • Here the implemented code :

    <embed id='flashvideo' name='flashvideo' src='http://lkcast.com/mediaplayer/player.swf' width='600' height='600' bgcolor='#000000' allowscriptaccess='always' allowfullscreen='true' flashvars='playlistfile=http%3A%2F%2Flkcast.com%2Fxml_save_new%2F2011%2F12%2F15%2F3651e6de9825ff067b4722134abb3ccc1323968208.xml&skin=http%3A%2F%2Flkcast.com%2Fmediaplayer%2Fskins%2Fmodieus.swf&playlist=bottom&repeat=list' />

    I don't even load a plugin.

    Please guys need your help.

    Up Down 0 rated
  • There is I believe something missing in your coding.

    There are several different method that you can use. The way that you do it is not my chocie in using the JWPlayer

    here is some documentation that may be of help to you

    http://www.longtailvideo.com/support/jw-player/jw-player-for-flash-v5/12538/supported-player-embed-methods

    If you wish, feel free to visit my web site, look at th examples there by clicking on the view code button

    www.mirana.net

    feel free to contact me from off my web site IF I can be of further help

    Up Down 0 rated
  • THank you very much for your quick answer,

    But the thing is the video works fine with the same code till 1 weekago.

    I'm trying to understand what could happen from last week.

    Up Down 0 rated
  • did you update your player? is it current?

    Up Down 0 rated
  • It's a good point, i've just upgraded to the lastest version 5.8.2011..

    I'm still getting the same error on chrome.

    :-(

    Up Down 0 rated
  • @Laki – You do have Flash installed for Chrome, right?

     
    Up Down 0 rated
  • i'm having same problem i uninstalled flash player then re installed it still getting "missing plug-in" message Please Help

    Up Down 0 rated
  • Link?

     
    Up Down 0 rated
  • Hello Ethan,

    Yes flash player is correctly installed in chrome.
    I'm not the only one having this trouble, some members of the website wrote me about this issue.

    This thing is very stange, it works perfectly there 1 week ago on chrome. (Is it due a chrome new upgrade ?)

    Up Down 0 rated
  • I have Chrome updated and do not have issues.

    Do you have an error here, too, in Chrome? – http://www.longtailvideo.com/support/jw-player-setup-wizard

     
    Up Down 0 rated
  • I have the latest Chrome (16.0.912.63) on Windows XP and your video works for me.

    Up Down 0 rated
  • I'm on Windows 7 (french)

    No i don't have the error on your link, it works correctly.

    Up Down 0 rated
  • I tried this simple script without any customized flash vars as skin.

    <embed id='flashvideo' name='flashvideo' src='http://lkcast.com/mediaplayer/player.swf' width='600' height='600' bgcolor='#000000' allowscriptaccess='always' allowfullscreen='true' flashvars='file=http://content.longtailvideo.com/videos/flvplayer.flv' />


    I saved the html file on my local pc and open the html file with chrome, I'm still getting the error message.

    And tried on my server, same error.

    here the link : http://lkvideos.com/jw-player-chrome.html

    Up Down 0 rated
  • Guys,

    There is definetly some thing wrong with the embed implemetation on the latest chrome web browser, JW Player and Win7

    I've uploaded a new html file to my server with my simple embed script and the script which is in Longtail's Setup Wizard

    Here have a look, both of them are not working properly.

    link : http://lkvideos.com/jw-player-chrome.html

    Example 1 is my costomiezd script

    Example 2 is the longtail's setup wizard script

    Up Down 0 rated
  • Laki

    I used Chrome and no error message

    btw, the latest version of Chrome is 17.0.963.12 which was released today 16/12/11.

    has something changed at the ISP by chance?

    ISPs are notorious in making unannounced changes.

    Btw, the link above renders in the "Quirks" mode which is somethign you want to avoid at all cost.

    a bien tot et bon fete semain

    Up Down 0 rated
  • Dear Willie Meier,

    First of all thank you very much for tring to help me.

    Actually i'm not using the 17.0.963.12 but the 16.0.912.63 m

    I have no idea about this issue.

    I'm on Win7 (64bit)

    Up Down 0 rated
  • Must be a windows 7 thing.

    Up Down 0 rated
  • laki

    so am I win7-64bit and a win XP which is use largely for "Internet Exploder", ooops I mean IE8

    I am leaning towards an issue that is a combination of win7 and Chrome.

    I don't know Chrome as well as I do FF, as I use FF as my primary development tool.

    To be more definitive in response, I need to look at a the actual link and not a test page or link.

    IF I may suggest, feel free to visit my web site, www.mirana.net and peek around at the different examples and the coding used, it may offer a greate rinsight for you.

    feel free to contact me IF you wish.

    Si vous crivez en franais que je parle couramment le franais, je n'ai aucune question.

    Up Down 0 rated
  • I have Win7, newest Chrome and video on my site is OK for me.
    But much visitors told me, that they have missing plugin error in Chrome. In Firefox is video OK...

    Up Down 0 rated
  • I am more convinced than that this isn't a JWPlayer issue BUT still not
    100%.

    I wonder if anyone has ever "Googlized" the subject of "missing plugin in chrome"? wow, I just did and voila information to the "ying-yang" appeared on the screen.

    I am sure everyone is aware that Google Chrome is packaged with the flash player, right?

    Up Down 0 rated
  • Same problem here after updating to 16.0.912.63.
    Interesting fact: if u add *type="application/x-shockwave-flash"* to the <embed> code it will work fine. Found it here: http://userscripts.org/scripts/show/120154

    Up Down 0 rated
  • I changed old embed code to inserting with jwplayer.js and its working now... So problem is with <embed> code, use jwplayer.js. Swfobject.js maybe works too

    Up Down 0 rated
  • Thanks Yarr Me!

    your fix works - add type="application/x-shockwave-flash" to the <embed> code

    This is a bug with Chrome they changed there way of doing things - so they need to fix on next update...

    see my post to chrome forum here

    http://www.google.com/support/forum/p/Chrome/thread?tid=14c2194db07fac6c&hl=en

    also respect to Ethan - still love jwplayer for embedding.

    Up Down 0 rated
  • okolookolo - might be right if we can change the .js would that be a work around?

    as I have lots embeds that were embedded a while ago which now don't work in chrome -

    and impossible to edit all of them...but editing the .js that the videos reference would that solve it?

    Up Down 0 rated
  • Ok guys…just catching up here. This looks to be a Chrome specific issue, not a JW Player issue. However, I did just upgrade Chome today (again) on Win XP, to the latest version, and I went to our site, and everything seems fine. Does it look like they fixed it?

     
    Up Down 0 rated
  • Found that disabling chromes internal plugin and only using the addon works also.

    ( under the hood / Content Settings / Plugins (have to click the details top right )

    Disable the built in one and magic .. it works again . .!

    Up Down 0 rated
  • Cool!

     
    Up Down 0 rated
  • This solved it for me.
    (under the hood / Content Settings / Plugins)
    There were two versions of Shockwave Flash
    I disabled 11,1,102,55
    Now videos play fine using 10,3,183,5

    But what about our users?
    They would think something is wrong with JWPlayer and not view our videos.

    Up Down 0 rated
  • Also to add, this mentioned by others above DID NOT work for me:

    add type="application/x-shockwave-flash" to the <embed> code

    Up Down 0 rated
  • Adding type="application/x-shockwave-flash" to the embed code worked for my site - the flash was working, but had a horrible black background. Firefox and IE were fine, while even portable versions of Chrome were broken. Is this a case of Chrome "fixing" an issue that affects websites using bad or incorrect code?

    Up Down 0 rated
  • Perhaps with this posting I'm opening "Pandora's Box".

    IMHO, I would not use the embed element or tag with the JWPlayer.
    It is deprecated and only present as a backward compatibility for Netscape which is now defunct.

    It is a non-standard element simply for the sake of accessibility rather than validity. Using the JWPlayer's native embed method is far more superior, efficient and effective.

    I would even venture further in stating that using the swfobject with the JWPlayer is equally pass; too old as its initial release was in 2005 and updated in 2007.

    Using a technique called "Googlize" for this thread's topic will and does reveal a wealth of information on the thread's topic.

    Perhaps, it is time that the documentation for the JWPlayer be re-vamped, updated and with far more examples. For a good product irrespective of its type, it is the documentation that is its
    'Achilles Heel'.

    bc.. <embed> (Embedded Object)

    This widely supported but nonstandard element specifies an object, typically a multimedia element, to be embedded in an HTML document.

    This is the proprietary syntax once used with Netscape and in HTML3.2

    <embed

    accesskey="key"
    align="absbottom | absmiddle | baseline | bottom |
    left | middle | right | texttop | top"
    alt="alternative text"
    class="class name(s)"
    code="filename"
    codebase="url"
    height="pixels"
    hspace="pixels"
    id="unique alphanumeric identifier"
    language="javascript | jscript | vbs | vbscript | xml"
    name="string"
    src="url"
    style="style information"
    title="advisory text"
    unselectable="on | off"
    vspace="pixels"
    width="pixels"

    </embed>



    here is a link that will give a greater insight to the thread's topic

    http://geekius.com/internet/web-updates/chrome-missing-plug-in-fix/

    Up Down 0 rated
  • Guys, this isn’t a JW specific bug here. Chrome updated again this weekend, at least for me, and it is still working fine.

     
    Up Down 0 rated
  • I used the type="application/x-shockwave-flash" and it worked great for me.

    Up Down 0 rated
  • I meant the wmode="transparent"

    Up Down 0 rated
  • Ok!

     
    Up Down 0 rated
  • Ethan are you on mac or pc?

    Up Down 0 rated
  • pc!

     
    Up Down 0 rated
  • and the old embed is working for? you what is number of the google update?

    Up Down 0 rated
  • I just upgraded to a new PC and did a fresh install for chrome (latest version), still worked. Not sure what you mean by “old embed” though.

     
    Up Down 0 rated
  • here is what I mean by an old embed


    <object><embed src="etc.

    Up Down 0 rated
  • sorry here is an example http://wiziwiz.com/old.html

    Up Down 0 rated
  • You should update your player.swf from 5.7.1864 to 5.7.1896 or 5.8…

     
    Up Down 0 rated
  • Google has certainly motivated me to change my embed habits.

    For the record, adding:

    type="application/x-shockwave-flash"

    ...does indeed work.

    Unfortunately, there is far too much old code to go back and edit all of it. And our users will not perform any of the hacks being discussed here.

    Seems our best bet is to take this conversation over the Google Chrome help board and start a ruckus there.

    Up Down 0 rated
  • adding type="application/x-shockwave-flash" to the <embed> code
    IS NOT working for me, here is that part of the code:

    <embed
    modes: [
    {type= 'html5'},
    {type= 'flash', src: 'player.swf'},
    {type= 'application/x-shockwave-flash'},
    {type= 'download'}
    ]

    />

    I also tried having double quotes and
    {type= 'application/x-shockwave-flash', src: 'player.swf'}
    but still fails

    Up Down 0 rated
  • It is the better to use the native JWPlayer embed
    with many examples of using such on my web site in either the audio or video section.

    www.mirana.net

    You'll also be able to view the code used by clicking on the 'view code' icon

    Up Down 0 rated
  • Thanks Ethan!

    updating the player works!


    also from now on from now on I will use the jwplayer native embed also

    :)

    Up Down 0 rated
  • Np! :)

    Everyone – Use the JW Embedder. – http://www.longtailvideo.com/support/blog/15827/using-the-jw-embedder-to-embed-your-player

     
    Up Down 0 rated
  • I'll help anyone who needs help in using the JW embedder.

    I do suggest that visit my web site peek at the examples by viewing the code used then if you have any queries or need help feel free to ask.

    Up Down 0 rated
  • True, but a good tutorial is a good starting point too.

     
    Up Down 0 rated
  • /** THIS FAILED **/
    <embed
    modes: [
    {type= 'html5'},
    {type= 'flash', src: 'player.swf'},
    {type= 'application/x-shockwave-flash'},
    {type= 'download'}
    ]

    /** THIS WORKED!! **/
    <embed
    modes: [
    {type= 'html5'},
    {type= 'flash', src: 'player.swf'},
    {type= 'download'}
    ]
    type="application/x-shockwave-flash"
    />

    Does my "modes: [ ] " above look okay?

    Up Down 0 rated
  • That makes no sense. You can’t even put modes inside of an embed tag! They are totally incompatible.

     
    Up Down 0 rated
  • @Ethan LongTail...

    Thank you for confirming...I was driving myself mad thinking on the "modes" in a HTML tag!

    Solved. Add the Type to the legacy <embed> and did try disabling both Flash plug-ins under the bonnet and then enable both. Thank you guys!

    Up Down 0 rated
  • Np!

     
    Up Down 0 rated
  • Hey guys,I have the same problem with google chrome too. I am accessing the news site with embeds but it cannot play the embed file on my chrome browser but it plays fine on my IE.

    here is the site i am trying to access:

    http://lifestyle.inquirer.net/28821/learning-the-basics-of-sous-vide-cooking-part-ii

    Up Down 0 rated
  • I've just run across this problem myself, and I'm glad I'm not the only one. Rather than just posting a "me too", I do have something to add.

    Chrome doesn't use the downloaded plugin from Adobe, instead it has a built-in version of flash, which is the same version as what's currently on the adobe site (11.1.102.55).

    If you install the plugin from Adobe's site for any other browser (Safari/Firefox) on your machine, you can actually switch Chrome to use that. Open Chrome and go to chrome://plugins. Under "Flash" you should see two versions, one is enabled and the other disabled. The paths will be something like %AppData%LocalGoogleChrome...gcswf32.dll (built-in) and windowssyswow64macromed...npswf32.dll (downloaded from Adobe).

    I found you can turn the problem on and off by enabling and disabling the two plugins. It works perfectly using npswf32.dll and fails with gcswf32.dll every single time.

    It's too much to ask users browsing the sites to use the adobe plugin, so it needs fixing... but who gets to fix it?

    Now who gets to fix it?

    Alex.

    Up Down 0 rated
  • @Rick – Is this your site?

    @Alex – Yes, thanks for sharing. Chrome uses it’s own version. There isn’t much we can do here though.

     
    Up Down 0 rated
  • is there a way to find out if our users are running into the same problem?

    Up Down 0 rated
  • You would have to ask them if they are.

     
    Up Down 0 rated
  • if you use adblock in your chrome browser just shut it off and jwplayer should work properly

    Up Down 0 rated
  • Thanks for sharing.

     
    Up Down 0 rated
  • I'm seeing the same missing plugin issue with the chrome/chromium browsers and sites using jw player.

    see http://community.flixster.com/tv/google
    * try playing a trailer

    Linux 3.2.6-3 SMP

    chromium-17.0.963.46-3
    google-chrome-stable-17.0.963.56-121963

    Up Down 0 rated
  • This site is using 5.2, which is pretty outdated at this point.

     
    Up Down 0 rated
  • It does seem to be related to the version of jw player. Just tried two sites with versions 5.3 and 5.9 and both worked.

    Thanks Ethan

    Up Down 0 rated
  • Np

     
    Up Down 0 rated
  • Is a Chrome issue. Update it and Voil!

    Up Down 0 rated
  • Yep. Chrome should auto update by itself anyways ;)

     
    Up Down 0 rated
  • I had the same "missing plugin" issue with JW Player and Chrome. I downloaded the Chrome extension "Missing Plug-in Fix" by herophuong93 and it now works. The extension says, "A simple extension to fix error "missing plugin" when browsing flash content for Google Chrome."

    Up Down 0 rated
  • Cool, glad you got it working.

     
    Up Down 0 rated
  • We've embedded some video on our non-profit website - works fine in IE and Firefox but the videos won't play in Chrome. See http://www.communitylegalcentre.ca/services/Deaf.htm - can anyone tell me what we've done wrong? Much appreciated!!

    Up Down 0 rated
  • This is not our product…

     
    Up Down 0 rated

This QA is closed.

Still don't have JW Player? Get It Here