"Error loading media: File could not be played" error in JW Player 6 while playing mp4 with Chrome html5

This thread may refer to an older version of JW Player! Check our articles for the most up-to-date information.
This Q&A thread was imported from our previous system and could apply to an older product.
  • Hi,
    I am not able to play mp4 file in Chrome with HTML5 mode in JwPlayer 6. But the same video is playing fine in all other browsers with Flash. And IE 9 also it is working fine. But I am getting the error only in Chrome with HTML5 in My windows Machine.

    Machine Configuraiton:
    Operation Systems: Windows 7,8
    Browser : Chrome (Version 23.0.1271.95 m)
    JwPlayer: Version 6

    This is code I am used:

    bc.. jwplayer("video_frame").setup({
    logo: { file: '../Content/images/video_watermark_color.png', hide: 'false', position: 'top-left', linktarget: 'collaaj.com', margin: '10', over: '1', out: '0.8' },
    file: 'https://collaajteststorage.s3.amazonaws.com/a6b8b5bc-9f5c-4c1e-8a43-e7522787c355/e3a30a3b-1700-4646-a151-2afec1c93880.mp4',
    height: 360,
    width: 640,
    stretching: "uniform",
    "controlbar.idlehide": true,
    events: {
    onPlay: function () {
    AddView();
    }
    },
    image: 'https://collaajteststorage.s3.amazonaws.com/a6b8b5bc-9f5c-4c1e-8a43-e7522787c355/e3a30a3b-1700-4646-a151-2afec1c93880.jpg'
    });



    *Strong*My test url: http://dev.collaaj.com/Video/VideoPlayback?vid=2f9c2551-1cde-4f4e-8eeb-0b5bbf822f17


    Intresting part is video in "http://www.longtailvideo.com/jw-player/"...which is Jwplayer home page...in chrome also giving the same error.

    So I think there is bug in JwPlayer 6 fro Chrome????

  • I just opened your link in Chrome and it works fine. Did you solve the issue?

     
    Up Down 0 rated
  • ON IE my player showing this error"Error loading player:
    Flash version must be 10.0 or greater"

    Url is :http://www.playeragencies.com

    Up Down 0 rated
  • I just opened your link in IE. Works fine.

     
    Up Down 0 rated
  • My player is working, except on Windows 7 Internet Explorer. Flash is up to date. any ideas?
    http://www.fleetwoodonsite.com/ppSD2/catalog.php?id=5

    Works with Chrome and IE on XP, and Chrome on Win 7, but not Win 7 IE
    get error loading media file could not be played

    Up Down 0 rated
  • That's in an iframe, the source page is at
    http://www.fleetwoodonsite.com/a4m/samples.html

    Up Down 0 rated
  • This works for me in IE9, Win7, but I would recommend updating to 6.1 – http://account.longtailvideo.com/

     
    Up Down 0 rated
  • Thanks for your quick response. Ok, I updated 6.0 to 6.1, no change. That's weird that 6.0 would work for you on Win 7 IE 9, It tried Win 7 IE 9 on 3 different computers. It only works on XP in IE 8 and Chrome for me.
    http://www.fleetwoodonsite.com/a4m/samples.html
    .

    Up Down 0 rated
  • JW 5.9 works on Win7 IE9.
    http://www.fleetwoodonsite.com/a4m/samples5.9.html

    But JW (6.0 or 6.1) doesn't seem to work in Win7 IE9. Am I missing something?
    I don't like going backwards. JW 6 worked on iPhone too, but this is just Flash.

    Up Down 0 rated
  • I have had these exact problems since purcashing JW player 6. Its a piece of crap. It boasts that it falls back to the appropriate player type, flash, html5, download, for the browser, but it does no such thing.

    Browsers it DOES NOT work on:

    Windows 7 IE9
    Windows XP IE7 and IE8
    OSX Chrome
    Windows XP Chrome
    Ubuntu Chromium

    This is a mega fail. I want my money back or any old version! We have a live site with paying customers. This is unacceptable.

    Up Down 0 rated
  • @Steve – Your link has issues in HTML5 mode (Flash mode is fine), in IE9, because the video’s mime type is – application/octet-stream, but it should be video/mp4. The reason this works in JW5 is because the default rendering engine is Flash, but in JW6, the default mode is HTML5.

    @Tyguy7 – Please, provide a link.

     
    Up Down 0 rated
  • I am having the same issue (the error) in Chrome when loading an mp4. The problem does not exist with webm videos, but then I cannot play the video in IE. Is there any way to point Chrome to a webm source and the other browsers to an mp4? Or alternatively, although not preferably, is it possible to force Chrome to use flash?

    My website is here:
    http://bejank.com/Home.html

    At the bottom of the page are three tiles under "Animations". The first brings up a webm video (which plays in Chrome), and the other two are mp4s (which don't play in chrome). There are no issues with either format in Firefox (although the mp4 defaults to flash).

    Thanks.

    Up Down 0 rated
  • Never mind, I figured it out myself.
    I deleted the source tag and added this:

    bc.. sources: [{
    file: "Videos/PingPong440blue.webm",
    width: "100%",
    height: "100%"
    },{
    file: "Videos/PingPong440blue.mp4",
    width: "100%",
    height: "100%"
    }],



    Why I think this works:
    By putting webm first, it causes Chrome, which can play both file types, to play it instead of the mp4, while IE, which cannot play webm, defaults to mp4.

    Up Down 0 rated
  • Glad you got it, thanks for sharing.

     
    Up Down 0 rated
  • hi guys,

    my problem using this JWPlayer is I can't play the .flv format in IE9.it shows "Error loading media: File could not be played". i also have ask my friend to tested on IE10, and only voice of the video can heard. but everything works fine for mp3 format..

    anyone has the solution/suggestion?thank you.

    Up Down 0 rated
  • Do you have a link?

     
    Up Down 0 rated
  • actually i'm doing this on my server.

    Up Down 0 rated
  • so now i got the answer.

    the JWPlayer6 is not support for the latest flash player. thats why i just get to hear the voice only.

    Up Down 0 rated
  • That is not correct. I use the latest version of Flash, JW6 works just fine. Check your video card drivers.

     
    Up Down 0 rated
  • Ethan, you were correct. I had mp4 mime type set to be application/octet-stream in the .htaccess on the server to force some file types to download instead of play in a browser. But, I don't need that, not for every directory anyway. I removed that line and JW6.1 now also works in Win7 IE9. I never had this problem before, but I wasn't using the playlist feature, which apparently calls the MP4 files differently than the standard JW embed.

    Thanks very much Ethan! I don't know if I ever would have figured that out on my own.

    Up Down 0 rated
  • oh really?because i just test on my friend's laptop that have the latest flash player.but it didn't work. let say, if it's really about my video card drivers..why is that?because i really don't know about the card driver and what needed to be done of that's is the problem..

    thank you Ethan for all the replies and suggestions. :))

    Up Down 0 rated
  • @afiqdoherty Can you see this video? http://www.fleetwoodonsite.com/test This is an FLV using JW 6.1. I can see it in Win 7 IE 9. Do you have a URL of your video that doesn't work?

    @Ethan LongTail - How did you know the mime type was my problem?

    Up Down 0 rated
  • @Steve – Np! I was able to tell by using Firebug’s Net Panel :)

    @afiqdoherty – It works for me as well?

     
    Up Down 0 rated
  • I'm getting this same error here http://staging.usewheel.com in Windows 7 IE 9, then Windows 7 Firefox 12.0, is displaying a "download file" dialog when clicking play.

    Up Down 0 rated
  • Should like you don’t have Flash installed…

     
    Up Down 0 rated
  • I have very strange version of this problem (or probably this is a new problem).

    In Chrome in Windows 8 my video starts ok, plays 4 seconds and than I get the message "Error loading media: File could not be played".
    In IE it gives the message immediately, without any playback.

    The same video goes ok in Chrome/Firefox in Windows 7 on other computers.
    Here is the video: http://www.d-ria.ru/video/test.htm

    Up Down 0 rated
  • This works for me.?

     
    Up Down 0 rated
  • Works? What configuration do you use? Chrome/Windows 8? And if yes then do you have any idea on what can cause this problem? I checked it on two computers with Chrome/Windows 8 and had this problem on both.

    Up Down 0 rated
  • Yes, I checked a test PC in the office with Chrome/Win8. Maybe it has to do with your video card drivers possibly?

     
    Up Down 0 rated
  • Thank you, Ethan. Now I found that both these two computers cannot play video even from the home page of your site. That is - cannot play any videos in JWPlayer, if it must be played in built-in mode, within a page.
    But both computers play any video without problems in VLCPlayer, if it played locally, or if VLCPlayer is called by the browser (this took place in Firefox and Opera). And both computers have no problem with youtube.
    And they are from two different manufacturers. The only common thing I can see is that they use Windows 8/Chrome.

    Did you see the same situations before? I am stuck with this situation as I cannot imagine a problem with card driver that stops working the only one program and lets all others to show video. Perhaps, this is possible, but how can I fix it then?

    Up Down 0 rated
  • Np. I don’t really know of issues like this, as our site is viewed a lot every day, and there not really many reports of even videos on our site not working, though…

     
    Up Down 0 rated
  • Thanks, Ethan

    Up Down 0 rated
  • Np

     
    Up Down 0 rated
  • Hi.

    I have the same error as Kiran also i can't see the jwplayer homepage video on chrome, It gives me a "Error loading media: File could not be played". Do you have any clues? a fix?

    When a put primary : "flash" it works on all browsers but i do not like flash. Does it get html5 player on mibile browsers like tablets or mobiles although i put primary : "flash"?

    I apologize for my poor english and thanks for your replies and help.

    Up Down 0 rated
  • Do you have a link?

     
    Up Down 0 rated
  • Sorry, i can not give you a link because is under development, but it hapens also on longtailvideo jwplayer homepage New York video on my Chromo. It's because i am so shoked. There are many people that reported the same thing.

    Can you please answer the question of the previous post? automatic HTML5 player on mobile browser althought u wrote primary : "flash" on my code?

    Again thanks for your time and help.

    Up Down 0 rated
  • Sorry, that doesn’t happen for me on our site.

    Of course it will play HTML5 on mobile, Flash isn’t supported on mobile, so it is going to flash, then failing back to html5…

     
    Up Down 0 rated
  • When viewing this site in Internet Explorer 9 I get "Error loading media:" when attempting to play the video. However, if I change to Compatibility Mode the video will play normally.

    http://dev.vireoinvestments.com/flash.htm

    Up Down 0 rated
  • Make sure your server has the MP4 MIME TYPE set.

     
    Up Down 0 rated
  • It is. I've already set it before I made the test page.

    The server is Windows Server 2008 and IIS7.

    Up Down 0 rated
  • Do you need to emulate IE8?
    have you tried without using this meta?

    Up Down 0 rated
  • Your MIME TYPE is actually slight incorrect.

    It is – video/mpeg

    It needs to be – video/mp4

     
    Up Down 0 rated
  • Quite right. I changed it as you suggested and the video loads and plays in standard IE9 browser format. Thank you.

    Up Down 0 rated
  • Ii also need help!!! When I open it has the error thing and I'm on my itouch :link:http://chia-anime.com/mstream.php?id=42047

    Up Down 0 rated
  • Nope it's not working in chrome "Error loading media : File could not be played "

    Up Down 0 rated
  • Having the same problem here. My conditions:

    Windows 8
    Running from localhost (test environment)
    Chrome 24.0.1312.57 m
    IE 10.0.9200.16466

    Loading a playlist without specifying 'type': 'mp4' variable, I get "Error loading player: No playable sources found" immediately, before I even get the play button on the screen.

    Loading a playlist with 'type': 'mp4' variable, in Chrome it gives me "Error loading media: File could not be played" after pressing the play button on the screen. In IE, I get no play button and no error, just "JW Player" at the top right of the screen????

    Loading a playlist with 'type': 'mp4' and 'primary': 'flash' variables, I get "Error Loading media: File not found" after pressing the play button on the screen. The player controls very briefly flashes at the bottom of the screen.

    If I copy the URL for any of the video files in the playlist and set the source file to that, the videos all play fine. Not sure what the issue is here. The playlist files work fine on our previous versions of JWPlayer, I'm just doing a little testing to see if we should buy the HTML5 player.

    Up Down 0 rated
  • I should specify, the playlist files are in this format:

    bc.. <playlist xmlns="http://xspf.org/ns/0/" version="1">
    <title>Mycompany's playlist for Video Date</title>
    <tracklist>
    <track>
    <title>Video Title 1</title>
    <location>
    http://www.mycompanyswebsite.com/06ed814a-dfde-4e40-9c58-1f0cc8e0b01c.mp4
    </location>
    </track>
    <track>
    <title>Video Title 2</title>
    <location>
    http://www.mycompanyswebsite.com/418c2466-e0f4-4a7e-9a83-a00b27f3814d.mp4
    </location>
    </track>
    </tracklist>
    </playlist>



    The only thing I can think of is maybe it's not loading .mp4 files from a playlist the same way as when you pass the .mp4 file in directly through the 'file' variable.

    Up Down 0 rated
  • Ethan I'm having a problem with viewing in IE 9 also.

    The error message is "error loading media; file could not be played". I've read through all this posts and I'm not sure how to go about fixing this.

    Link: http://www.posmessaging.com/demo.html

    Up Down 0 rated
  • I'm using BrowserStack to test my video and I see that it is not playing in:

    XP - IE 6 & 7 - Pop-up saying "Companion.JS v0.5.5 no error/1 log"
    7 - IE 9 - "error loading media; file could not be played"

    Anyone figure out how to fix this?

    Up Down 0 rated
  • I've also been fighting with IE9 not playing while every other player was playing the video correctly.

    Just wanted to say thanks to Ethan on the mime type lead.


    I added this to my .htaccess file and now even IE works :)

    AddType video/mp4 .mp4 .m4v

    Up Down 0 rated
  • What is the .htacess file? I just have two .js files

    Up Down 0 rated
  • To who I helped and got it working – Np!

    To who is still having issues, please provide links.

    If you don’t know how to set your MIME TYPEs, ask your host !

     
    Up Down 0 rated
  • I get the error noted in the header of this issue every 2nd to 3rd time I load this test page link.

    http://www.xosdigital.com/player/JWPlayer6.htm

    Load it a couple of times and it make work or give you error.
    Keep loading it and you'll see it go from working to not working to working and back again
    Here is the code on that page. It is a very simple test. I am also using the free version for a test and got the license key from a wizard. The video file is signed but that has not been an issue with any other version of jwplayer. We are currently running 5.7 on all of our sites.

    <script type="text/javascript" src="/player/jwplayer-6.2/jwplayer.js"></script>
    <script>jwplayer.key="8pLnpHjLtdUPJIeYlljF3sGRDwxmZEA7rkEKsw=="</script>
    <body>
    <div id="wrapper" runat="server">
    <div id="rtmpplayer" runat="server">
    <div id="xosrtmpplayer">xosrtmpplayer</div>
    <script type='text/javascript'>
    var jwplayer_config = {
    autostart: "true",
    canFireAPICalls: true,
    height: "360",
    width: "600",
    allowscriptaccess: 'always',
    allowfullscreen: true,
    stretching: "fill",
    controlbar: "bottom",
    file: 'http://d9h4t5ii70mc4.cloudfront.net/xossports/downloads2/17ac4401-7439-4bfb-88b5-da6d907b80a3_xos-cms-mp4-s3_download.mp4?Expires=1360862690&Key-Pair-Id=APKAJQ42JP5J5WCIBJDA&Signature=iwMLYEmYG0rp9-cnhiWLqdBTTsFy5Be8Qibkjcgiz0bCGBH~soRzZGh7ohw3DrHYghfPhT~xUKKPi6hUiOFW6ppNX4N3Sl8Ic9RGwFMwHziR~wnR14Z-JUxyTPk8X~v2OzzmMmSmEAZpZecp22GwH3NVhN-sPeEGz0ygh1joeIQ_}'
    }
    jwplayer('xosrtmpplayer').setup(jwplayer_config);
    </script>
    </div>
    </div>
    </body>

    Up Down 0 rated
  • Your link works fine for me?

     
    Up Down 0 rated
  • I am running it in chrome. I can consistently refresh and watch it go back and forth between working and not working between every other refresh. Sometimes it works 3 times in a row and sometimes I get an error the second time.

    Up Down 0 rated
  • I checked Chrome. It worked 10+ times for me so far.

     
    Up Down 0 rated
  • Ethan, seriously, even your homepage has the same error. It will play about 5 seconds and then say "Error loading media: File could not be played". I'm on Windows 8 using Chrome. The same video works fine on IE10 and Firefox.

    Up Down 0 rated
  • Same here. Viewing a course in Litmos Chrome 24.0.1312.57 m on Windows 8.

    Video displays for 2 seconds and then same error "Error loading media: File could not be played"

    Only happens on one machine (at the moment). Made sure firewall/content blockers off, cache cleaned, flash updated. I have played this on same version of Chrome (in a parallel Windows 8 VM) fine and another colleague played fine on Windows 8 with same ver of Chrome as well.

    Plays on IE and Firefox fine on all machines.

    Up Down 0 rated
  • I believe that you guys are having the issues, but we haven’t been able to reproduce. I would recommend updating your video card drivers.

     
    Up Down 0 rated
  • Yep, replacing Windows 8 generic with specific video drivers for the Dell laptop fixed the issue. Thanks.

    Up Down 0 rated
  • Np

     
    Up Down 0 rated
  • My Problem: could not connect to application: Error #2004

    I'm using the following:
    <ul>
    <li>*- Plugin: JW Player Plugin for WordPress Version 1.7.2*</li>
    <li>*- Wordpress: WordPress 3.4.2.*</li>
    </ul>
    This is the error I found before the video started
    *"could not connect to application: Error #2004"*
    It's always show the loading image.

    This is the link: http://chinaimportformula.net/

    Can you Help me out? Please...

    Sincerely,
    Ambhen

    Up Down 0 rated
  • What is the full path to your rtmp server?

     
    Up Down 0 rated
  • Anyone has fixed the problem?
    I played the link as follows with the same problem.
    http://www.opencompute.org/summit-2012/#

    But I can normally play all the above listed links.
    I use Win7 and IE9.

    Up Down 0 rated
  • Is this your site?

     
    Up Down 0 rated
  • http://www.momente-deosebite.tk/video1.html
    here mai website ethan.I see a problem on chrome and mozzila.ON IE work.

    Up Down 0 rated
  • How did you encode your file?

     
    Up Down 0 rated
  • I am experiencing similar problems.
    On Windows 7 64 bit IE 9 I receive the "Error loading media: File could not be played".
    On Windows 7 32 bit FF 19.0 I don't see the player at all.
    At least with FF it all started when I upgraded flash from 10.3.183.20 to 11.6.602.171. Downgrading back to 10.3.183.20 fixes my problem with FF. The mp4 file plays in the flash player. I can't expect users to do this though.

    My .htaccess file looks like this:
    SetEnv no-gzip dont-vary
    # Video
    AddType video/ogg ogv
    AddType video/mp4 mp4 m4v
    AddType video/webm webm

    Link to page is:
    http://players.hitdawgacademy.com/index.php?route=videos/videotest

    Video plays in Windows 7 64 and 32 bit Chrome, Windows 7 32 bit IE explorer 9 , and Safari on iPad. Video also plays on Android.
    Many of my mp4 files have the metadata at the end of the file, which I am working on resolving. Could that be the problem?
    Can anyone offer some ideas as to what I can do to resolve this issue?

    Up Down 0 rated
  • Update to my prior post:
    I believe my mime type could be the problem. Can anyone tell me how I can confirm this when I'm looking at the firebug?

    Up Down 0 rated
  • Your link works in Chrome for me.

     
    Up Down 0 rated
  • Thanks Ethan,
    It works in Chrome for me as well. The problem I'm having is it is not playing in IE 9 on 64 bit systems, nor can I get it to play in FireFox after upgrading to the latest version of flash.
    If it works in other browsers, can I assume that the mime information is not the issue?

    Up Down 0 rated
  • The MIME is fine. I checked IE9 and FF and it works for me as well?

     
    Up Down 0 rated
  • Can you tell me what version of flash you are on? I am on windows 7 32 bit and flash version11.6.602.171. I can't see the player in FF.
    Someone I am working with has Windows 64 bit IE 9 and they receive the error: "Error loading media: File could not be played".

    Up Down 0 rated
  • Same version. Can you have others check as well?

     
    Up Down 0 rated
  • I will have people test it out.

    Up Down 0 rated
  • Okay.

     
    Up Down 0 rated
  • One person has responded informing me that the video now plays in Window 64 bit IE 9. That is promising. However, I still cannot see the player in Windows 7 32 bit FF 19.0. Downgrading flash seems to be the only thing that works for me with FF.
    I wish I knew why.

    Up Down 0 rated
  • Sorry, I have checked this same config as well and it works.

     
    Up Down 0 rated
  • I am experiencing the same issue with Chrome and Chrome alone. It gives the "Error loading media: File could not be played" error whenever I initial click play. If I repeatedly click this button it does eventually start playing the video until I stop the video. If I let it play until completion again it works fine. If I stop it and try to play again, I get the same error.

    I'm running this on a localhost so I cannot share, but it is working in IE9, Firefox, and Safari.

    bc.. <script>jwplayer('mediaplayer1').setup({
    file: 'video/clipcanvas_14348_H264_640x360.mp4',
    image: 'image/tokyo-27-740x335.jpg',
    width: 740,
    height: 335,
    events:{
    onComplete:function(){jwplayer('mediaplayer1').stop()},
    onPause:function(){jwplayer('mediaplayer1').stop()}}});
    </script>

    Up Down 0 rated
  • Can you put something up?

     
    Up Down 0 rated
  • AdBlock off and flash plaer will work!!

    Up Down 0 rated
  • Not sure what you mean?

     
    Up Down 0 rated
  • not work when redirect to file in chrome..

    Up Down 0 rated
  • you can check link file http://m1.phimbig.com/movies/5136fe69e25ab4186cbd025e/426x240/the-perks-of-being-a-wallflower-cau-chuyen-tuoi-teen-2012.mp4

    Up Down 0 rated
  • Just checked this mp4 in our wizard and it worked fine in Chrome.

     
    Up Down 0 rated
  • it only happend once for me in your wizard video, happens much often when testing locally on my mp4 file

    try to click very fast multiple times back and forward, fast clicking on the timeline triggers this error

    Up Down 0 rated
  • here are screenshots, once it produced an error, second time - when clicking a lot back and forward - player gets busy and it turnes black, in this state reloading page helps only, player doesn't unblock itself

    http://imageshack.us/f/27/bug2sy.jpg/
    http://imageshack.us/f/855/bug1c.jpg/

    Chrome: 25.0.1364.152 m

    Up Down 0 rated
  • Sorry, but I can’t replicate this on my machine.

     
    Up Down 0 rated
  • I did replicate this on 2 machines, I can't replicate this on 1 desktop but it doesn't change anything.
    I would like to assume you will try on different machines, different OS...???

    there is a bug in the player and by replicating this on your own demo video I eliminated issue on video side

    seems to happen on chrome only (windows 7 in my case)

    Up Down 0 rated
  • I have Win7/Chrome, still can’t replicate on our end. I have checked on our demo videos.

     
    Up Down 0 rated
  • Ethan-I am also experiencing the very same problem with Chrome. It doesn't seem to matter whether it's on a Windows XP Pro machine or a Windows 7 64bit. I get the same error in Chrome. The test video works fine in IE 9 and FireFox. Am I missing something? This is for a free training site we're developing.

    Link: http://www.getinthegameseries.com

    Up Down 0 rated
  • Your mp4 never plays for me, even in Firefox.

     
    Up Down 0 rated
  • Then what is wrong, and what do I need to do to fix it? It does work for me in IE 9 & FireFox, but just not in Chrome. What am I missing?

    Up Down 0 rated
  • It does, however, take time to load in both IE 9 & FireFox.

    Up Down 0 rated
  • Ah, this is an encoding issue. Use this tool to fix it – http://renaun.com/blog/2010/06/qtindexswapper-2/

     
    Up Down 0 rated
  • Thanks Ethan. I'll try this. Just as a note, my analytics do show 6 views on Friday, March 9-4 of the first version & 2 of the revised 2nd version. Although I just tried all 3 browsers again, with the same exact result (OK in IE 9 & FireFox, but error in Chrome), these 2 views don't show yet in the analytics.

    I'll give this a try.

    Up Down 0 rated
  • Np.

     
    Up Down 0 rated
  • Hi there.

    I also have problems with the mime type. Is there a parameter to force the flash player until HTML5 is working?

    It's a bit complicated to have to change the server configuration just to use HTML5 while Flash is working fine...

    Of course I could use an older version but if I pay for something, it would be better if it works...

    Up Down 0 rated
  • I have a couple of LAMP servers running a custom-designed LMS using the JW6 player. This was a recent upgrade (this week). As with the avalanche of other commenters in this thread, I am getting numerous complaints about inaccessible video content. Strangely enough I cannot replicate the problem on any of my machines or in any of the browsers I use (IE, Chrome, Firefox). Most of our subscribers are NOT having a problem, which makes this even more difficult to understand.

    I followed the troubleshooting guide recommendation and had every support requested clear their cache and cookies and check their Flash version--no joy. I checked my Apache mime configuration file and yes, the mime type was video .mp4/mp4 (our videos are formatted in H.264...).

    I realize this is one of those subtle issues that can be hard to fix, but I've got to have this fixed today, or roll back to JW5. You can believe if that happens, I won't get clearance to change back to JW6, or any future upgrades.

    Throw me a bone Ethan--what else can I do?

    Up Down 0 rated
  • @nb – For JW6, you can set the player’s primary variable to flash, to force flash mode.

    @Andrew – Can you put something up that we can debug? I understand that you want it fixed today, but it will be hard to figure out an issue that we can’t see.

     
    Up Down 0 rated
  • Ethan:

    Thanks for the tip on "proper encoding" and the Renaun tool you recommended, to fix my problem. It worked, to the best of my knowledge, in IE 9, Chrome & Firefox, at least for me.

    I would appreciate it if you would check it out, for me, from your end. The link again, is http://www.getinthegameseries.com Let me know if it works, in all three browsers, for you as well.

    Also, since I'm a newbie at "video encoding," and the use of JW Player, please explain to me what the encoding problem was, and what I did to correct it.

    Once I understand all the facts & fixes, I will then be able to continue developing this video training series. Thanks again for your help.

    Up Down 0 rated

This QA is closed.

Still don't have JW Player? Get It Here