Embed Code not working in internet explorer

This thread may refer to an older version of JW Player! Check our articles for the most up-to-date information.
This Q&A thread was imported from our previous system and could apply to an older product.
  • I would really like some ...I would really like some help with this. The following code is to produce a player that plays two movies. This works in Firefox but only plays one movie in IE or Safari.

    <!-- START: FILMTRAILER.COM FLASH PLAYER version 3.3 -->
    <object width="400" height="225">
    <param name="movie" value="http://www.player.filmtrailer.com/v3.3/player.swf?file=http://uk.player-feed.filmtrailer.com/v2.0/cinema/1511|1508/?channel_user_id=441100227-1"></param>
    <embed type="application/x-shockwave-flash" src="http://www.player.filmtrailer.com/v3.3/player.swf?file=http://uk.player-feed.filmtrailer.com/v2.0/cinema/1511|1508/?channel_user_id=441100227-1&default_quality=xlarge&display_title=none&volume=35" allowFullScreen="true" width="400" height="225"></embed>
    </object><br/> <a style="font-family: verdana; color:cccccc; font-size:
    8pt; text-decoration:none" alt="filmtrailer.com" target="_blank" href="http://uk.filmtrailer.com/">Film Trailers by Filmtrailer.com</a>
    <!-- END: Provided by filmtrailer.com -->

    I would really appreciate some help.

    Thanks

    Chris

  • me too, help!!!!

    Up Down 0 rated
  • This is explorer 7 & 8. Any help out there?

    Up Down 0 rated
  • The problem is to do with the vertical bar as a separator.

    One film works fine, but when I try to add another film using the vertical bar | as a separator it onlys plays one.

    But it will play both in Firefox.

    Up Down 0 rated
  • We have fixed this now. encoding our source according to UTF-8. I.e.

    <!-- START: FILMTRAILER.COM FLASH PLAYER version 3.3 -->
    <object width="400" height="225">
    <param name="movie" value="http://www.player.filmtrailer.com/v3.3/player.swf?file=http://uk.player-feed.filmtrailer.com/v2.0/cinema%2F1508%7C1513%7C1524%7C1418%2F%3Fchannel_user_id%3D441100227-1" />
    <embed type="application/x-shockwave-flash" src="http://www.player.filmtrailer.com/v3.3/player.swf?file=http://uk.player-feed.filmtrailer.com/v2.0/cinema%2F1508%7C1513%7C1524%7C1418%2F%3Fchannel_user_id%3D441100227-1" allowFullScreen="true" width="400" height="225"></embed>
    </object><br /> <a style="font-family: verdana; color:cccccc; font-size: 8pt; text-decoration:none" alt="filmtrailer.com" target="_blank" ref="http://uk.filmtrailer.com/">Film Trailers by Filmtrailer.com</a>
    <!-- END: Provided by filmtrailer.com -->

    Up Down 0 rated
  • @my site (www.dieperbeeld.nl) single films don't work in IE either.

    This is the code:
    bc.. <div id="player1" style="text-align:left"><a href="http://www.macromedia.com/go/getflashplayer">Get the Flash Player</a> to see this player.</div>
    <p> <script type="text/javascript" src="swfobject.js"></script><br />
    <script type="text/javascript">
    var s1 = new SWFObject("player.swf","ply","360","288","9");
    s1.addParam("allowfullscreen","true");
    s1.addParam("allowscriptaccess","always");
    s1.addParam("flashvars","file=/wp-content/filmMarco.flv&fullscreen=true");
    s1.write("player1");
    </script></p>



    and this is the code as I fixed it in Wordpress:
    bc.. <div id="player1" style="text-align:left"><a href="http://www.macromedia.com/go/getflashplayer">Get the Flash Player</a> to see this player.</div>
    <script type="text/javascript" src="swfobject.js"></script>
    <script type="text/javascript">
    var s1 = new SWFObject("player.swf","ply","360","288","9");
    s1.addParam("allowfullscreen","true");
    s1.addParam("allowscriptaccess","always");
    s1.addParam("flashvars","file=/wp-content/filmMarco.flv&fullscreen=true");
    s1.write("player1");
    </script>


    The players work fine in Firefox

    Any suggestions?

    thanks in advance,

    Jef

    Up Down 0 rated
  • @Jef,

    You don't wrap the JavaScript code for the player in a paragraph element.bc.. <divid="player1"style="text-align:left">
    <ahref="http://www.macromedia.com/go/getflashplayer">GettheFlashPlayer</a>toseethisplayer.
    </div>
    <scripttype="text/javascript"src="swfobject.js"></script>
    <scripttype="text/javascript">
    vars1=newSWFObject("player.swf","ply","360","288","9");
    s1.addParam("allowfullscreen","true");
    s1.addParam("allowscriptaccess","always");
    s1.addParam("flashvars","file=/wp-content/filmMarco.flv");
    s1.write("player1");
    </script>



    Theflashvar*fullscreen*isread-only,soIremoveditfromyourcode.

    Pleasereviewthev4.xplayersupportedflashvarshere:

    *http://developer.longtailvideo.com/trac/wiki/FlashVars#Behaviour*

    Your problem with Internet Explorer is probably related to the Adobe Flash Player. Go to Adobe's site and get the uninstaller. Uninstall, reboot, reinstall the Adobe Flash Player.

    Up Down 0 rated
  • @ LefTy,

    Thanks for your quick response.

    A frind of mine just fixed it. Like this:

    bc.. <!--start_raw-->
    <script type="text/javascript" src="swfobject.js"></script>
    <script type="text/javascript">
    swfobject.registerObject("player4", "9.0.0");
    </script>
    <div>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="365" height="312" id="player4">
    <param name="movie" value="player.swf">
    <param name="allowfullscreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="flashvars" value="file=/wp-content/filmMarco.flv">
    <!--[if !IE]>-->
    <object type="application/x-shockwave-flash" data="player.swf" width="365" height="312">
    <param name="allowfullscreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="flashvars" value="file=/wp-content/filmMarco.flv">
    <!--<![endif]-->
    <a href="http://www.adobe.com/go/getflashplayer">
    <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player">
    </a>
    <!--[if !IE]>-->
    </object>
    <!--<![endif]-->
    </object>
    </div>
    <!--end_raw-->


    This way the IE gets a different treatment.

    Regards,

    Jef

    Up Down 0 rated
  • The conditional code is not necessary, but if it works, good luck!

    Up Down 0 rated
  • doesn't this work without javascript so it works on myspace too?

    Up Down 0 rated
  • Will you help me get this to play in IE?

    <embed src="player.swf" width="432" height="240" loop="false" bgcolor="undefined" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" allowscriptaccess="always" allowfullscreen="true" flashvars="file=videos/customers_speak/rto_testimonial.flv&image=videos/customers_speak/wills.jpg&controlbar=over" play="false"/>

    Up Down 0 rated
  • The Jef one worked perfect!, thanks!



    <!--start_raw-->
    <script type="text/javascript" src="swfobject.js"></script>
    <script type="text/javascript">
    swfobject.registerObject("player4", "9.0.0");
    </script>
    <div>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="365" height="312" id="player4">
    <param name="movie" value="player.swf">
    <param name="allowfullscreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="flashvars" value="file=/wp-content/filmMarco.flv">
    <!--[if !IE]>-->
    <object type="application/x-shockwave-flash" data="player.swf" width="365" height="312">
    <param name="allowfullscreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="flashvars" value="file=/wp-content/filmMarco.flv">
    <!--<![endif]-->
    <a href="http://www.adobe.com/go/getflashplayer">
    <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player">
    </a>
    <!--[if !IE]>-->
    </object>
    <!--<![endif]-->
    </object>
    </div>
    <!--end_raw-->

    Up Down 0 rated
  • thank u 4 all

    Up Down 0 rated
  • please help me about this code is not working IE

    Up Down 0 rated
  • You need a second object element for Internet Explorer.

    See: *http://www.longtailvideo.com/support/forum/Setup-Problems/13856/Multiple-playlists-on-blogger#msg93968*

    Up Down 0 rated
  • thank you

    Up Down 0 rated
  • Currently using JW player as a solution to implement streaming video from a third party. Works great except that the embed code generated after the video does not work.

    <embed src='http://devlogos.com/sites/default/files/player-licensed-viral.swf' height='267' width='400' allowscriptaccess='always' allowfullscreen='true' flashvars='file=http%3A%2F%2Fdevlogos.com%2Flogosministries%2Fvideos%2Foldtestament%2Fbible_blasts_001a.flv&image=http%3A%2F%2Fsalemnet.vo.llnwd.net%2Fo29%2Flogosministries%2FBible%20Blasts%20Pictures%2FOne%20Stone.jpg&streamer=rtmp%3A%2F%2Fsalemnet.fcod.llnwd.net%2Fa3186%2Fo29%2F&plugins=viral-1d'/>

    When I remove the escaped characters manually the embed code works -

    <embed src='http://www.devlogos.com/sites/default/files/player-licensed-viral.swf' height='267' width='400' allowscriptaccess='always' allowfullscreen='true' flashvars='image=http://salemnet.vo.llnwd.net/o29/logosministries/Bible Blasts Pictures/Naked People.jpg&streamer=rtmp://salemnet.fcod.llnwd.net/a3186/o29/&file=logosministries/videos/specialtopics/bible_blasts_015.flv&volume=100&plugins=viral-1d'/></embed>

    Any suggestions on getting JW player to generate the correct code automatically would be very appreciated.

    Up Down 0 rated
  • These two embed codes aren't remotely the same - they don't reference the same file, and the second has a streamer, while the first doesn't.

    How are you generating the first embed code from the second?

    Up Down 0 rated
  • I cant get any of the codes below to work in IE can someone please help. I have tried all combinations of the embed code and still cant get anything to work in IE

    <script type='text/javascript' src='swfobject.js'></script>

    <div id='mediaspace'>This text will be replaced</div>

    <script type='text/javascript'>
    var so = new SWFObject('http://complimentssalonandspa.com/files/player-viral.swf','mpl','634','357','9');
    so.addParam('allowfullscreen','true');
    so.addParam('allowscriptaccess','always');
    so.addParam('wmode','opaque');
    so.addVariable('file','http://complimentssalonandspa.com//files/playlist/Compliments-Homepage-Intro.mp4');
    so.addVariable('controlbar','none');
    so.addVariable('autostart','true');
    so.write('mediaspace');
    </script>



    Or


    <object classid='clsid:D27CDB6E-AE6D-11cf-96B8-444553540000' width='634' height='357' id='single1' name='single1'>
    <param name='movie' value='http://complimentssalonandspa.com/files/player-viral.swf'>
    <param name='allowfullscreen' value='true'>
    <param name='allowscriptaccess' value='always'>
    <param name='wmode' value='transparent'>
    <param name='flashvars' value='file=http://complimentssalonandspa.com//files/playlist/Compliments-Homepage-Intro.mp4&controlbar=none&autostart=true'>
    <embed
    type='application/x-shockwave-flash'
    id='single2'
    name='single2'
    src='http://complimentssalonandspa.com/files/player-viral.swf'
    width='634'
    height='357'
    bgcolor='undefined'
    allowscriptaccess='always'
    allowfullscreen='true'
    wmode='transparent'
    flashvars='file=http://complimentssalonandspa.com//files/playlist/Compliments-Homepage-Intro.mp4&controlbar=none&autostart=true'
    />
    </object>

    Up Down 0 rated
  • Thanks for you help and quick response

    Up Down 0 rated
  • Can you please expand on your comment?

    Where in the code should I place
    MP4Box -inter 0.5 Compliments-Homepage-Intro.mp4


    Thanks

    Up Down 0 rated
  • Also is there a reason why IE will show the video on one occasion then on the next no video just audio?

    Up Down 0 rated
  • MP4 box is a command line tool that you use to process your MP4 files once. It doesn't go in any code for the player.

    Up Down 0 rated
  • Hi I want to embed a page in a wordpress and it is working in Chrome but not in explorer, the code I'm using is:

    <object width="920" height="950"><param name="search" value="http://www.realtysoft.com/idx/122ada4e8290a3eb0d586b95d12b055d"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.realtysoft.com/idx/122ada4e8290a3eb0d586b95d12b055d" type="" allowscriptaccess="always" allowfullscreen="true" width="920" height="950"></embed></object>

    Please help!

    Up Down 0 rated
  • Can you provide a link to where you are running this?

     
    Up Down 0 rated
  • Terrible! You guys should get this fixed. It's a seriously annoying error that should implement the solution the same in all browsers not just Mozilla type.

    Up Down 0 rated
  • Peter – You will need embed and object tags if you want the player to work in all browsers, that is just how it different web browsers work. Do you have a link to where you are experiencing the error?

     
    Up Down 0 rated
  • Hi the flex gallery on this page is giving me a lot of troubles.

    I have read all your conversation. I cannot import external script and also with SWF objects doens't work on IE bastard

    http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&item=370355245882

    The strange things is that if I click with mouse ( left click on gallery ) and then I push TAB button it starts to work...

    Any IDea?

    HEre is code
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

    type="application/x-shockwave-flash" width="900" height="200"

    data="http://www.modacalcio.com/FlexComponents/ProductGalleryAuction/gallery.swf">
    <param name="allowFullScreen" value="false" />
    <param name="allowscriptaccess" value="always"></param>
    <param name="src" value="http://www.modacalcio.com/FlexComponents/ProductGalleryAuction/gallery.swf" />

    </object>
    <object width="900" height="200">
    <param name="movie"

    value="http://www.modacalcio.com/FlexComponents/ProductGalleryAuction/SmoothScrollingHorizontalList2.swf"

    ></param>
    <param name="allowFullScreen" value="false"></param> <param name="allowscriptaccess"

    value="always"></param>
    <param name="wmode" value="transparent"></param>
    <param name="scale" value="Showall"></param>
    <param name="flashVars" value="marca=adidas&tipo=maglia_calcio&squadra=chelsea&ebay=1"></param>
    <embed

    src="http://www.modacalcio.com/FlexComponents/ProductGalleryAuction/SmoothScrollingHorizontalList2.swf"

    type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="false"

    wmode="transparent" flashVars="marca=adidas&tipo=maglia_calcio&squadra=chelsea&ebay=1" scale="Showall"

    width="900" height="200"></embed></object>

    Up Down 0 rated
  • Ok, I am also having issues with the viral player. People have complained that the embed code available for them to put on their sites is not working in IE. I have tested and its not. I need to find the solution for this ASAP.

    I cannot find anything about this anywhere on the boards except this thread which is only lightly talked about which I find amazing that this hasn't been a big issue for others.

    Is the escaped characters causing the IE issue and if so how to resolve it?

    Honestly, I am more than a little miffed that this is an issue. Thank you in advance for any help in the right direction.

    Up Down 0 rated
  • Mark – Can you provide a link to where you are running this?

     
    Up Down 0 rated
  • <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','99','height','33','src','images/audio/1 rich harlan mp3','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','images/audio/1 rich harlan mp3' ); //end AC code
    </script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="99" height="33">
    <param name="movie" value="images/audio/1 rich harlan mp3.swf" />
    <param name="quality" value="high" />
    <embed src="images/audio/1 rich harlan mp3.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="99" height="33"></embed>
    </object>
    </noscript>

    Up Down 0 rated
  • winContent+='<object type="application/x-shockwave-flash" data="http://www.ebible.com/twop/player.swf" id="audioplayer1" height="24" width="250">';
    winContent+='<param name="audio" value="http://www.ebible.com/twop/player.swf">'
    winContent+='<param name="FlashVars" value="playerID=1&soundFile=http://www.ebible.com/twop/'+ quality +"/"+ audio_file +'">'
    winContent+='<param name="quality" value="high">'
    winContent+='<param name="menu" value="false">'
    winContent+='<param name="wmode" value="transparent">'
    winContent+='</object>'


    This is the code for embedding the flash player in my html file. i have a player.js file inplace. it works fine in safari and firefox but dosent work in IE .Any help is appreciable.....

    Up Down 0 rated

  • Worksperfectlyforme:bc.. <scriptsrc="http://complimentssalonandspa.com/files/swfobject.js"></script>

    <divid="mediaspace"><ahref="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash">GettheAdobeFlashPlayertoseethisvideo.</a></div>

    <scripttype="text/javascript">
    varso=newSWFObject('http://complimentssalonandspa.com/files/player-viral.swf','mpl','634','357','9.0.124');
    so.addParam('allowscriptaccess','always');
    so.addParam('allowfullscreen','true');
    so.addVariable('file','http://complimentssalonandspa.com//files/playlist/Compliments-Homepage-Intro.mp4');
    so.addVariable('controlbar','none');
    so.addVariable('autostart','true');
    so.write('mediaspace');
    </script>




    Youshoulduse:bc.. MP4Box-inter0.5Compliments-Homepage-Intro.mp4
    tointerleavetheboxes,sothevideofilestartsquickly.

    Up Down 0 rated
  • Thanks Jef,
    your way worked for me.

    Up Down 0 rated

This QA is closed.

Still don't have JW Player? Get It Here