RTMP no buffering?

This thread may refer to an older version of JW Player! Check our articles for the most up-to-date information.
This Q&A thread was imported from our previous system and could apply to an older product.
  • The title says it all really. getbuffer gives a value of 0 all the time, suggesting jwplayer isnt creating a buffer...

    Im using jwplayer to show a live audio+video stream via RTMP (red5).

    It plays and works etc, but it buffers every few minutes, ruining playback for viewers.

    I've obviously tried buffer sizes from 5 to 60 seconds but get the same issue.

    I've tried setting duration to 0, -1 and 99999, thinking it may alter the buffering behaviour but it does not.

    Using getbuffer var suggests that the buffer size is always 0?

    Is this is a jwplayer bug or am i missing something?

    Code is as below:

    jwplayer('container').setup({
    'flashplayer': 'xxxxxxx',
    'allowscriptaccess': 'always',
    'allowfullscreen': 'true',
    'autostart': 'true',
    'playerID': 'video1549067',
    'image': 'xxxxxx',
    'streamer': 'xxxxxxx',
    'file': 'xxxxxxxx',
    'duration': '0',
    'bufferlength': '30',
    'volume': '100',
    'mute': 'false',
    'controlbar': 'none',
    'stretching': 'fill',
    'icons': 'false',
    'wmode': 'windowed',
    'width': '360',
    'height': '270',
    'plugins': {
    'gapro-2': {
    'trackstarts': 'true',
    'trackpercentage': 'false',
    'trackseconds': 'true'
    }
    }
    });

  • @Rick -

    When the player is playing content from an RTMP server, the buffer is not exposed. This is because unlike progressive download or HTTP pseudo-streaming, RTMP will only download enough of the content to display it without having to pause, so the player doesn’t report buffer percentages.

    Keep in mind, bufferlength and getBuffer are not directly related, even if the player did expose buffer percentages in the API during RTMP playback.

    My guess is that this is more a question of your server implementation and/or bandwidth, and not a function of the player’s behavior.

     
    Up Down 0 rated
  • So I'm wondering by default, what is the buffer length for streaming media? I'm using adaptive streaming in Flash mode (via adaptiveProvider.swf), and trying to obtain the bufferred content returned from getBuffer() call. But as expected, it returns "0".

    Or, is there any way I can adjust the default bufferring behavior for adaptive streaming?

    Up Down 0 rated
  • The buffering behaviour for HLS cannot be adjusted. We buffer typically 1 or 2 fragments ahead, but playback already starts (in 6.1+) when “some” video is received.

     
    Up Down 0 rated

This QA is closed.

Still don't have JW Player? Get It Here