Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

YouTube videos cutoff before the end


Hi All,

I've just integrated my ...Hi All,

I've just integrated my player to be able to play YouTube videos and it seems that the videos get cutoff about 5 seconds or so before the end of the video. The audio plays all the way through but the video goes back to the play graphic before the end.

Anyone have a possible solution to this?

Thanks much,

89 Community Answers

JW Player

User  
0 rated :

Oh and here's an example URL on my site where you can see my implementation and the issue.

http://yourtakes.com/takes/view/93

FF 3.5.5
Fedora 11

JW Player

User  
0 rated :

I really do, too. Sometimes the video ends a few seconds before of the end, the videos are cut off suddenly.
Some solutions.

Ethan Feldman

JW Player Support Agent  
0 rated :

@ciberlinker – Can you provide a link to where you are running this?

JW Player

User  
0 rated :

Not always occur, is random, sometimes I watch the videos well and others are cut and finish seconds before the end of the video (the status bar loaded to end well.) With any video, do not know why this happens, but I'm not alone. I have videos from other sources (vimeo, trilulilu, etc) and I have no problem only occurs on Youtube.
The video was cut a few hours ago now complete, it is random. And sometimes continuous.

JW Player

User  
0 rated :

http://maxiocio.net/disturbed/inside-the-fire-video_994209536.html

Ethan Feldman

JW Player Support Agent  
0 rated :

It works fine for me.

I suggest updating your copy of yt.swf with the one that comes with the latest player, which can be downloaded here – http://www.longtailvideo.com/players/jw-flv-player/

Pablo

JW Player Support Agent  
0 rated :

@ciberlinker -

I have actually seen this issue, and I believe I know what’s happening. The YouTube ActionScript API seems to stop sending time events, and then sends a “complete” status, a second or two before the video is actually done. There isn’t much the JW Player can do to get around this, since YouTube doesn’t send any additional content when this happens.

The JW Player still uses the old AS2 YouTube API, which has been deprecated. We will be moving to the AS3 version of the API soon, which will likely address this issue.

http://developer.longtailvideo.com/trac/ticket/580

JW Player

User  
0 rated :

Having exactly the same problem with my Youtube videos on my Wordpress site. Looking forward to a possible version with a fix for this bug. Thanx a lot!

Ethan Feldman

JW Player Support Agent  
0 rated :

Can you provide a link to where you are running this?

JW Player

User  
0 rated :

Same problem! Anything new? For example overstream doesn't have this bug with YouTube videos.

JW Player

User  
0 rated :

My site: bc.. http://www.videacesky.cz/

Ethan Feldman

JW Player Support Agent  
0 rated :

I just went to your site, and viewed this video – http://www.videacesky.cz/serialy/me-and-my-dick-%E2%80%93-1%C3%9705-%E2%80%93-pripravy-na-noc, the player played it all the way until the end (07:52).

JW Player

User  
0 rated :

Yes, but it is very random. Many people complain that they can't see whole video. Try for example this one:
bc.. http://www.videacesky.cz/hudba/ok-go-here-it-goes-again

Play the video at the bottom. It has just 12 seconds and when you play it several times and very likely, it will happen to you too.

Pablo

JW Player Support Agent  
0 rated :

@BugHer0-

When I go to that link, the player doesn’t show up – it says “Missing Plug-In” where the player should be. I have Flash 10,1,53,64 installed.

JW Player

User  
0 rated :

I have the same problem in firefox.
In opera is everything ok.
I am using also wordpress.

Ethan Feldman

JW Player Support Agent  
0 rated :

Can you provide a link to where you are running this?

JW Player

User  
0 rated :

http://roztomilavidea.cz/pitbulterier-si-hraje-s-kachnatkem/

Ethan Feldman

JW Player Support Agent  
0 rated :

This video plays until the end for me.

I am using Windows XP, Firefox 3.6, Flash Player 10, what are you using?

JW Player

User  
0 rated :

firefox 3.6.6
FLASH: You have version 10,1,53,64 installed
windows 7

Ethan Feldman

JW Player Support Agent  
0 rated :

It could be an issue relating to 10.1, can you try to use 10,0,45,2 ?

JW Player

User  
-1 rated :

You Were Right. With this version (flash 10,0,45,2) it Works perfect. Thank you!
But I suspect that most users will eventually have a newer flash.

Ethan Feldman

JW Player Support Agent  
0 rated :

Yes, so for the future version of the player, we ill patch this issue then, thanks! :O)

JW Player

User  
0 rated :

Ethan when is this patch coming out? I'm using flash version 10,1,53,64 and see this with the latest version of the player (5.2) This is happening on ie, firefox and chrome on winxp

Ethan Feldman

JW Player Support Agent  
0 rated :

We are releasing a patch shortly. Stay tuned!

JW Player

User  
0 rated :

i am having the same problem with videos on a specific site (not youtube). every time i watch one of their videos, it freezes up close to the end like it's buffering and never resumes playing. i use firefox. what can i do?

JW Player

User  
0 rated :

here is the link: http://www.truthinhistory.org/who-was-melchisedec.html

Ethan Feldman

JW Player Support Agent  
0 rated :

@mark – the is the 4.7 player here, and it works fine, I am unable to replicate the issue. Is this your website?

JW Player

User  
0 rated :

Hi...
JW Player 5.2
Newest flash version 10.1
Demo: http://csko.sk/forum/tube/video.php?mode=item&id=jo9-bcbLn1Q

Thanks

Ethan Feldman

JW Player Support Agent  
0 rated :

@tomio – Are you using the latest copy of YT.swf?

JW Player

User  
0 rated :

Hello!
I have the same problem with videos from my site http://funnyvi.com
When they are from YouTube, they don't play the whole movie.

JW Player

User  
0 rated :

@Ethan
Yes, of course

Pablo

JW Player Support Agent  
0 rated :

@tomio -

I can’t replicate this issue. Can you provide a list of steps to take to make it happen?

Ethan Feldman

JW Player Support Agent  
0 rated :

tomio/Teri – Thanks, this looks like an issue with YouTube / 10.1 it seems. As a word around, you will have to manually add a duration to the video, so it plays to the end.

JW Player

User  
0 rated :

@Ethan
Do you mean this?
so.addVariable('duration','01:16');
It doesn't help.

Ethan Feldman

JW Player Support Agent  
0 rated :

@tomio – Change it to – so.addVariable(‘duration’,‘116’);

JW Player

User  
0 rated :

Is this going to be fixed?

Pablo

JW Player Support Agent  
0 rated :

@John -

As I mentioned before, I can’t reliably replicate this issue. Do you have a test page I could look at which demonstrates the problem?

JW Player

User  
0 rated :

I have the same problem as Teri on my site www.videacesky.cz. Many of our visitors are experiencing this problem... video cutoffs before the end. Sometimes 5 seconds, sometimes 10, but it's really annoying.

We set duration to all of our videos and it doesn't help at all. :-( This problem is just with YouTube and it's pretty random. Some people say that it's fine and they see tho whole video, but some dont and it doesn't matter if they have Firefox, Opera or Chrome, or different versions of Adobe Flash Player... it's just random event. I think it has something to do with the version of YouTube API. Can you fix that as soon as possible please? I'm willing to donate you some money if you will, because right now, it's the bigger problem for my website, which is based on translating YouTube videos. :-( Thanks for your answer.

JW Player

User  
0 rated :

I too have this problem.
If you are still looking for a test page:
http://www.longtailvideo.com/players/jw-player-now/ ;) (i tried it with the default rabbit video and these short ones http://www.youtube.com/watch?v=DE668huxdeM and http://www.youtube.com/watch?v=hS_Ots3My-A, all stopping prematurely )
It doesnt play the entire video.. but this doesn't occur all the time. I noticed that playing a video for the first time in a clean browser (cleared all caches) gives the best chance to reproduce the problem.

Is this still an issue with the YouTube API (http://developer.longtailvideo.com/trac/ticket/580) ?
And will there be a solution sooner than Flash 5.4 ? If so i'll have to change some things on our sites.

I hope you can fix this.
Thanx

JW Player

User  
0 rated :

I think everybody has this problem with YouTube videos, but just a few of us wrote here, because the most people use JW player to stream .flv videos from their own server. For YouTube videos, they can simply use YouTube embed code, so there is no point in using JW, but for people who use JW player captions plugin, so they can translate YouTube videos to different language, it's very serious problem.

Ethan Feldman

JW Player Support Agent  
0 rated :

@BugHer0 and @Bierflesje – Please try replacing your copy of yt.swf (YouTube API), with this file – http://developer.longtailvideo.com/trac/export/1209/tags/mediaplayer-5.0/yt.swf

Please let me know if that fixes it for you. Thanks.

JW Player

User  
0 rated :

Ethan: It looks like it doesn't. Do I have to wait for sometime or it should change immediately? Do you know where the problem is?

Ethan Feldman

JW Player Support Agent  
0 rated :

Hi,

It should happen immediately.

Does the V4 player do the same cut off issue, or is V5 only?

Best,
-Ethan

JW Player

User  
0 rated :

Ethan: I don't know. How do I find out? I use the newest version of JW player on my website.

JW Player

User  
0 rated :

Ethan: I tried it and it looks that the video doesn't cut off before end any more, but I'm not sure and a different problem just showed up. When I play video for few times, sometimes picture dissappears and I see preview image instead of a video. The sound is okay though. Can you help me?

Here is a link for a test video: http://www.videacesky.cz/nezarazene/test

JW Player

User  
0 rated :

And could you repair yt.swf file for JW Player 5.2, so I can use new skins and features? Thanks in advance.

Ethan Feldman

JW Player Support Agent  
0 rated :

@BugHer0 – Glad that it is working for you. Regarding your issue on – http://www.videacesky.cz/nezarazene/test, it works for me. I cannot replicate that bug. Regarding the repair of yt.swf, I did not create this file. However, you should still be able to use the new skins/features, regardless of what copy of yt.swf you are using, as that file does not impact the skins/features overall.

JW Player

User  
0 rated :

Try to play it several times. I ask our visitors and they experience the same problem with preview image, which I mentioned higher. And I tried to replace yt.swf on my site with yt.swf from JW player version 4.7 and then videos didn't play at all. :-( So I don't know, what to do.

Ethan Feldman

JW Player Support Agent  
0 rated :

I tried that, but what I suggest is this:

Download both the player and yt from here – http://developer.longtailvideo.com/trac/browser/tags/mediaplayer-4.7, and try to use those files.

JW Player

User  
0 rated :

I tried and it does the thing I wrote. It sometimes suddenly displays a preview image instead of a video, but sound is still going... I'll record it for you. Wait a minute.

Ethan Feldman

JW Player Support Agent  
0 rated :

@BugHer0 – I believe that you are having the issue. I just am not able to replicate here. I suggest trying out other versions of the player from – http://developer.longtailvideo.com/trac/browser/tags

JW Player

User  
0 rated :

Please, try to watch this so that you can understand my problem. This is an example of version 4.7 of your player: http://www.videacesky.cz/YouTubeAPItest.mp4

Watch the screen and the timeline.

Ethan Feldman

JW Player Support Agent  
0 rated :

Downloading now, thanks.

JW Player

User  
0 rated :

I thank you. I am desperate now.

Ethan Feldman

JW Player Support Agent  
0 rated :

Okay, I see the issue. It looks like you are having an issue with Scrubbing.

What Flash Player version are you using?

JW Player

User  
0 rated :

10.1.82.76, but I put a test video on our website today and many visitors experienced the same problem. I think it must be something in this yt.swf file, because I have never experienced this issue with JW player 5.2. JW player 5.2 didn't play the whole video instead, as I mentioned higher.

Ethan Feldman

JW Player Support Agent  
0 rated :

Have you tried 5.1?

Or, you can alternatively try 5.3 – http://developer.longtailvideo.com/player/trunk/fl5/player.swf

JW Player

User  
0 rated :

Still the same problem. So is it a problem with player.swf or yt.swf file?

Ethan Feldman

JW Player Support Agent  
0 rated :

Not, sure, to be honest. Again, I am not able to replicate this issue, but you can get all of the our old versions of both files to test with here – http://developer.longtailvideo.com/trac/browser/tags

JW Player

User  
0 rated :

Ethan: I think it must be the yt.swf file, because I tried it with .flv video from my own server and it wroked fine. My vide played the whole way and the preview image didn't pop out. Do you think that this problem will be repaired in the next version of JW player? When will this version come out? It' pretty big problem for my website. :-(

Ethan Feldman

JW Player Support Agent  
0 rated :

It must be yt.swf then…We will investigate. Have you tried other versions of yt.swf?

JW Player

User  
0 rated :

Yeah, all 5.x versions cut off YouTube video before the end (3-10 seconds) and all 4.x versions play the whole YouTube video, but sometime preview image pops out... so audio goes on, but you can't see video or captions... just preview image.

Ethan Feldman

JW Player Support Agent  
0 rated :

That is so bizarre. I really have not seen the preview image pop out issue ever before.

We do have the 3X player, which also supports YouTube. Maybe that will work for your specific situation?

JW Player

User  
0 rated :

I also have the same problem with the 5x players and youtube videos. Members on my board all had the same problem and were complaining. (Did not test other versions of the player). I had to remove my JW player because it kept cutting off the videos with about 5-10 seconds to go. I can put the player back up on my site if you guys really need to see it, but it is the same problem as everyone else is mentioning. I would really love to use JWPlayer I purchased so I can use ad solution, but with this bug it's not possible for me. I have the latest version of flash, and use latest firefox if that helps. I will help in any way I can to get this sorted out..

Ethan Feldman

JW Player Support Agent  
0 rated :

@Randy – Can you provide a link to where you are running this?

JW Player

User  
0 rated :

Hi Ethan,

I just re-uploaded the player. You can try these two links

http://rocketcatch.com/madden-10/254-how-rocket-catch.html

Once in a while it will play to the end, so you may want to watch the video a few times, it is definitely still doing it.

JW Player

User  
0 rated :

I couldn't post both links because of the spam filter. The one above should be fine by itself.

JW Player

User  
0 rated :

Randy: Yes, it's the exactly same problem I have with 5.x version of JW player. Please, please, try to fix it. I would be very grateful.

Pablo

JW Player Support Agent  
0 rated :

@Randy -

I tried to get your video to show the error, but wasn’t able to replicate the problem (I tried 10+ times).

JW Player

User  
0 rated :

We have the same problem, the videos get cutoff about 5 seconds by YouTube videos. We use Google-Chrome browser and the latest flash version... by playing a file from our webspace (for example a mpeg file) we don't have the issue...

(sorry for my bad english, i come from germany)

Ethan Feldman

JW Player Support Agent  
0 rated :

Yes, I am sorry, but I am also unable to replicate these cutoff issues…

JW Player

User  
0 rated :

All of us with the problem, let's list what player version, browser, and flash version we are using and anything relevant... maybe we can pinpoint something.

jwplayer 5.2
firefox 3.68
Adobe Flash Player version 10.1


Also, I am embedding jwplayer into vbulletin bulletin board software.

JW Player

User  
0 rated :

Ethan and Pablo can you do the same please?

Ethan Feldman

JW Player Support Agent  
0 rated :

That is my exact configuration:

JW Player 5.2
Firefox 3.68
Adobe Flash Player version 10.1
Win XP Pro is my OS

Pablo

JW Player Support Agent  
0 rated :

JW Player 5.2.1151
Chrome 5.0.x
Mac OS 10.6.4
Flash 10.1.82.76

JW Player

User  
0 rated :

JW Player 5.2
Google Chrome 5.0.375.70, but I tried also Firefox and Opera and many visitors on our site have the same problem no matter if they are using Opera, Chrome or Firefox...
Windows 7
Flash 10.1.82.76

JW Player

User  
0 rated :

We use

JW Player: v5.2.1151
Google-Chrome: v5.0.375.127
Adobe Flash-Player: v10.1.82.76
OS: Windows 7

and I discovered that this problem since the update to the latest version of flash. - In the previous version, it still worked!

JW Player

User  
0 rated :

Anything new? Are you working on this problem? Thanks.

Ethan Feldman

JW Player Support Agent  
0 rated :

I believe they are, yes. Please check the 5.3 player.

JW Player

User  
0 rated :

Hi, new version 5.3 doesn't have YouTube support? I don't see yt.swf file there. Thanks.

Ethan Feldman

JW Player Support Agent  
0 rated :

Yes it does.

You can download the 5.3 player.swf file and the yt.swf file here – http://developer.longtailvideo.com/trac/browser/trunk/fl5

JW Player

User  
0 rated :

YouTube video still doesn't play to the end. :-( I hoped that new version will fix this problem... I'm quite disspointed.

Ethan Feldman

JW Player Support Agent  
0 rated :

Link please. Thanks.

JW Player

User  
0 rated :

Ethan: Link for what? I posted my problem here several times and it's still the same. You're just gonna write "I am unable to replicate these cutoff issues." and that's all. I don't know what else should I do. I explained my problem to you, but it seems that nobody is trying to fix it. :-(

Ethan Feldman

JW Player Support Agent  
0 rated :

I would link to see:

A new link to where you are running the New 5.3 Player and the new yt.swf file.

Please provide that, so I can look at it, as well as the other members of the LongTail team.

Thanks.

Pablo

JW Player Support Agent  
0 rated :

@BugHer0 -

I believe I’ve discovered the cause of these issues. I’ve created a bug ticket: http://developer.longtailvideo.com/trac/ticket/1041. I should have a fix in place soon.

As for Ethan’s comment; having a test page with the most recent player and yt.swf will indeed help us to test the fix.

JW Player

User  
0 rated :

PabloS: That would be great. Thank you in advance and let me know, when it'll be done. I will try to set up a test page soon.

Pablo

JW Player Support Agent  
0 rated :

@BugHer0 -

A fix is in place. You can test it by grabbing the latest build of the player here:

http://developer.longtailvideo.com/player/trunk/fl5/player.swf

You’ll also need the latest yt.swf:

http://developer.longtailvideo.com/player/trunk/fl5/yt.swf

JW Player

User  
0 rated :

Thank you! - In version 5.3.1356 is the problem resolved. :)

This question has received the maximum number of answers.