Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Volume adjustment not working for YouTube videos


Hiya,

Im using the video player ...Hiya,

Im using the video player to play both locally hosted FLV files as well as some YouTube videos, the player works 100% fine for the local FLV's but when streaming YouTube videos, the volume control does not appear to work?

Regards

Rob

34 Community Answers

JW Player

User  
3 rated :

I too am experiencing the same problem. Have you had any success in finding a resolution to this?

JeroenW

JW Player Support Agent  
0 rated :

This is all working fine for me. Could you check two items?

1) Rightclick the player, choose “settings” and then set the “local storage” to 0. Youtube used to save a cookie that overrode the volume in their API.

2) Test the volume in the latest version of the player; the ‘Youtube featured videos’ section here:

http://developer.longtailvideo.com/trac/testing

JW Player

User  
0 rated :

When trying the test page yes it does in fact work. One of the things that I think is the problem is how we were trying to recompile the player with a different look instead of using a skin. I tested with a skin and everything works fine.

JW Player

User  
0 rated :

Hi,

I experience this problem with a standard local FLV (relative URL, though). After setting local storage to 0, the volume works, but a popup shows each time you change it to ask if you want to store the value... Pretty uncomfortable.

I tried everything, from muting to setting a hardcoded value, omit it... Nothing worked.

Help ! :s

JW Player

User  
-1 rated :

Right now my volume isnt working my speakers are working my volumes the right volume and event the video volumes right but why a I not getting any sound from any of the You Tube Videos????

JW Player

User  
-1 rated :

even im facing the same problem can any1 help me out of dis????

JW Player

User  
0 rated :

I have the very same problem. Audio files are working perfectly fine. Output from speakers is perfect. But youtube, and other flv/mp4 sites have no volume. No sound comes out of any of these players.
Can omeone please help?

JW Player

User  
0 rated :

I have the very same problem. Audio files are working perfectly fine. Output from speakers is perfect. But youtube, and other flv/mp4 sites have no volume. No sound comes out of any of these players.
Can omeone please help?

JW Player

User  
0 rated :

I have the same problem i don't know much about computers but my media player is working fine but the volume on you tube is not working at all!!! HELP!!!!

JW Player

User  
0 rated :

I have the very same problem. Some user have no audio with youtube videos. And i can say to all the user that configure storage to 0. Another solution?

JW Player

User  
0 rated :

I have had a similar problem.. the volume is turned up, the speakers are working and everything is plugged in.. but the things is. the sound doesnt work on my internet.. it works for everything else from testing the speakers to my iTunes.. and I dont know how to fix it :( It was working earlier this morning and just stopped..

JW Player

User  
0 rated :

hey had the same problem for 2 weeks! here's the solution from Youtube and it WORKS!!!!!!!!!!!!!!!!! ENJOY THE MUSIC AGAIN!!!!!!!!!!!!!!!!!!!!!!!! :-) http://help.youtube.com/support/youtube/bin/answer.py?hl=en&answer=58132

JW Player

User  
0 rated :

the volume control has a small red X next to the speaker icon that is also red. it usually does that when there is copyrighted material in the videos, but it does that to all the video i try to go one.
I have already restarted my laptop, but that didn't work. Help?

JW Player

User  
0 rated :

Tried your link Debbie but it does not lead anywhere. Comes up as "Bad Request"

JW Player

User  
0 rated :

Just noticced this issue

Using
Player-viral
Internet Explorer Version 6
Snel v1.0 skin

Found that the volume bar would not work playing a Youtube clip. It would remain on the initial volume it was when the page was opened.

I did a test where I would mute the sound then refresh the page, and the sound would still be muted, but not un-mute. Basically it would stay on the sound level it opened with.

Non youtube clips work fine and Firefox works fine. Hav not tested higher version of IE (if anyone can test please).

So I have issolated it to IEv6 and YouTube clips only....

Is it just a matter of putting in a backward compatibility script or line in the commands... ?????

JW Player

User  
0 rated :

The home page of longvideo works fine, love those girls, and I just noticed there is a new version of 4.5, so I am going to test the new version and try no skin or different skins and see if I can isoloate the problem.

JW Player

User  
0 rated :

I have uploaded v4.5 latest, I have changed the skins and the volume still does not adjust when using IE (any version)

I even went back to the wizard that longtail provide and chose the "flv with a youtube video" option and that doesn't work either. So if the example don't work on the longtail site then I have not answers.

Note that this is only a problem with IE and Youtube videos....

Should this be looked at by the programmers, as your own example doesn't work....

Here is my code that I use:

<!-- Template file for Flash Movies -->
<script type="text/javascript" src="http://mysite.com/swfobject.js"></script>

<div align=center id="player1"><a href="http://www.macromedia.com/go/getflashplayer"><font size=5>DOWNLOAD PLAYER HERE</font></a>
<br><font color="red" size=3>If you can read this then you need to download the FLASH player <br>to watch the movie</font>.<br>
TRY REFRESHING YOUR PAGE FIRST</div>
<script type="text/javascript">
var s1 = new SWFObject("http://mysite.com/player-viral.swf","single","425","355","7");
s1.addParam("allowfullscreen","true");
s1.addParam('allowscriptaccess','always');
s1.addParam('wmode','opaque');
s1.addParam('flashvars','file={media_src}&skin=http://mysite.com/snel.swf&image=http://mysite.com/jwplayer_press_play.png&link=http://somesite.com&displayclick=link&screencolor=1C1C1C&stretching=exactfit&icons=true&plugins=viral-1&viral.callout=mouse&viral.onpause=false&viral.functions=all&author=mysite.com&description=Whatever&title={image_name}');
s1.write("player1");
</script>

JW Player

User  
0 rated :

I have searched the entire site looking for an answer and considering this is quite a major flaw in the player, considering 90% of content out there is from youtube, I see no option but to uninstall.

JW Player

User  
0 rated :

Can't someone find a fix for this glitch? It's hard to believe.

JW Player

User  
0 rated :


Yes, it works in firefox perfectly - but not in IE. :/

JW Player

User  
0 rated :

Ugh I can't use youtube.
& the answers given on this site
are not working for me. I don't know
what the problem is. But i love youtube
& can't use it now ]: Help pleasee!

JW Player

User  
0 rated :

this isn't entirely true actually, the jw player volume works properly with some youtube videos.

Some of the youtube videos that still work are usually ones that were uploaded early 2007 or earlier. :/ Maybe youtube did something new ?

JW Player

User  
0 rated :

First discover if it is web sound altogether and not just youtube being a pain. If it is the web, here's the solution to your problem:

Copy this text into notepad (starting with Windows Registry Editor Version 5.00) and save it to your desktop using the name "missing.reg":

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
"midimapper"="midimap.dll"
"msacm.imaadpcm"="imaadp32.acm"
"msacm.msadpcm"="msadp32.acm"
"msacm.msg711"="msg711.acm"
"msacm.msgsm610"="msgsm32.acm"
"msacm.trspch"="tssoft32.acm"
"vidc.cvid"="iccvid.dll"
"VIDC.I420"="i420vfw.dll"
"vidc.iv31"="ir32_32.dll"
"vidc.iv32"="ir32_32.dll"
"vidc.iv41"="ir41_32.ax"
"VIDC.IYUV"="iyuv_32.dll"
"vidc.mrle"="msrle32.dll"
"vidc.msvc"="msvidc32.dll"
"VIDC.YVYU"="msyuv.dll"
"wavemapper"="msacm32.drv"
"msacm.msg723"="msg723.acm"
"vidc.M263"="msh263.drv"
"vidc.M261"="msh261.drv"
"msacm.msaudio1"="msaud32.acm"
"msacm.sl_anet"="sl_anet.acm"
"msacm.iac2"="C:\\WINDOWS\\system32\\iac25_32.ax"
"vidc.iv50"="ir50_32.dll"
"wave"="wdmaud.drv"
"midi"="wdmaud.drv"
"mixer"="wdmaud.drv"
"VIDC.WMV3"="wmv9vcm.dll"
"VIDC.VP40"="vp4vfw.dll"
"msacm.voxacm160"="vct3216.acm"
"MSVideo"="vfwwdm32.dll"
"MSVideo8"="VfWWDM32.dll"
"wave1"="wdmaud.drv"
"midi1"="wdmaud.drv"
"mixer1"="wdmaud.drv"
"aux"="wdmaud.drv"
"vidc.VP70"="vp7vfw.dll"
"vidc.X264"="x264vfw.dll"
"VIDC.FPS1"="frapsvid.dll"
"vidc.VP60"="vp6vfw.dll"
"vidc.VP61"="vp6vfw.dll"
"vidc.VP62"="vp6vfw.dll"
"vidc.DIVX"="DivX.dll"
"VIDC.UYVY"="msyuv.dll"
"VIDC.YUY2"="msyuv.dll"
"VIDC.YVU9"="tsbyuv.dll"
"VIDC.DRAW"="DVIDEO.DLL"
"VIDC.YV12"="yv12vfw.dll"
"wave2"="wdmaud.drv"
"midi2"="wdmaud.drv"
"mixer2"="wdmaud.drv"
"aux1"="wdmaud.drv"
"wave3"="wdmaud.drv"
"midi3"="wdmaud.drv"
"mixer3"="wdmaud.drv"
"aux2"="wdmaud.drv"
"VIDC.MSUD"="msulvc05.dll"
"wave4"="wdmaud.drv"
"midi4"="wdmaud.drv"
"mixer4"="wdmaud.drv"
"aux3"="wdmaud.drv"

After saving the file, go to START > RUN > and type 'regedit' and then click OK
In the registry, select FILE > IMPORT and select the "missing.reg" file from your desktop
You should get a confirmation that it was imported successfully.

This is an instant fix ... your speakers should now work for web sounds, then you may need to restart you computer.

Enjoy Sound Ayesha

=3

JW Player

User  
0 rated :

IN MY SYSTEM VOLUME IS NOT WORKING IF I WANT TO HERE ANY SONG THAN SOUND IS NOT COMING

JW Player

User  
0 rated :

hey somebody help me out..my youtube volume is not working at all :( pls help me

JW Player

User  
0 rated :

you tube is doing my head in

any help ?? :( :@

aarrggghhhhhhhh

JW Player

User  
0 rated :

I found a solution to the bug,
1. just download 4.5 version of the player source code,
2 .replace yt.as code with this :

*// Security domains
System.security.allowDomain('*');
System.security.allowInsecureDomain('*');


// Variables
if(!unique) { var unique = 1; }
var ytPlayer:MovieClip = this.createEmptyMovieClip("ytPlayer",this.getNextHighestDepth());
var ytPlayerLoader:MovieClipLoader = new MovieClipLoader();
var ytLocation:String = "http://www.youtube.com/apiplayer";
var _as3_to_as2:LocalConnection = new LocalConnection();
var _as2_to_as3:LocalConnection = new LocalConnection();
_as3_to_as2.allowDomain('*');
_as2_to_as3.allowDomain('*');

var connection:String;
var loadInterval:Number;
var byteInterval:Number;
var timeInterval:Number;
var loaded:Number;
var position:Number;
var GlobalSound = new Sound(ytPlayer);


// Interval handlers
function loadHandler() {
if (ytPlayer.isPlayerLoaded()) {
_as2_to_as3.send('AS2_'+unique,"onSwfLoadComplete");
clearInterval(loadInterval);
ytPlayer.addEventListener("onStateChange", onPlayerStateChange);
ytPlayer.addEventListener("onError", onPlayerError);
ytPlayer.unMute();
ytPlayer.setVolume(100);
}
};
function byteHandler() {
var btl = ytPlayer.getVideoBytesLoaded();
var ttl = ytPlayer.getVideoBytesTotal();
var off = ytPlayer.getVideoStartBytes();
if(ttl > 10 && btl != loaded) {
loaded = btl;
_as2_to_as3.send('AS2_'+unique,"onLoadChange",btl,ttl,off);
if(btl+off >= ttl) {
clearInterval(byteInterval);
}
}
};
function timeHandler() {
var pos = Math.round(ytPlayer.getCurrentTime()*10)/10;
var dur = Math.round(ytPlayer.getDuration()*10)/10;
if(dur > 3) {
if(pos == position && dur-pos < 10) {
onPlayerStateChange(0);
} else {
_as2_to_as3.send('AS2_'+unique,"onTimeChange",pos,dur);
}
}
position = pos;
};



// Event handlers
function onPlayerStateChange(stt:Number) {
clearInterval(timeInterval);
if(stt == 1) {
timeInterval = setInterval(timeHandler,200);
} else if (stt == 3) {
clearInterval(byteInterval);
byteInterval = setInterval(byteHandler,200);
timeInterval = setInterval(timeHandler,200);
}
_as2_to_as3.send('AS2_'+unique,"onStateChange",stt);
};
function onPlayerError(erc:Number) {
_as2_to_as3.send('AS2_'+unique,"onError",stt);
clearInterval(timeInterval);
};


// Directive forwards
_as3_to_as2.pauseVideo = function() { ytPlayer.pauseVideo(); };
_as3_to_as2.playVideo = function() { ytPlayer.playVideo(); };
_as3_to_as2.stopVideo = function(){ ytPlayer.stopVideo(); clearInterval(byteInterval); };
_as3_to_as2.loadVideoById = function(id,pos) {ytPlayer.stopVideo(); ytPlayer.loadVideoById(id,pos); };
_as3_to_as2.setVolume = function(vol) { ytPlayer.setVolume(100); GlobalSound.setVolume(vol) };
_as3_to_as2.seekTo = function(pos) { ytPlayer.seekTo(pos,true); };
_as3_to_as2.setSize = function(wid,hei) { ytPlayer.setSize(wid,hei); };


// Initialization
_as3_to_as2.connect('AS3_'+unique);
ytPlayerLoaderListener = {};
ytPlayerLoaderListener.onLoadInit = function() { loadInterval = setInterval(loadHandler,200); };
ytPlayerLoader.addListener(ytPlayerLoaderListener);
ytPlayerLoader.loadClip(ytLocation,ytPlayer);*

3 republish yt.fla and replace the yt.swf file of your player with the one you just published.

hope it helps.

JW Player

User  
0 rated :

i also have the same problem...i tried ayesha's instruction but still it's not working..when i opened run and typed "regedit", nothing showed up....HELP ME PLEASE!

JW Player

User  
0 rated :

hello everybody,

my player is installed, I am running a youtube playlist on it - it works perfect with firefox but with Internet Explorer I cannot adjust the volume.

anybody knows why?

thank you!
mattk

Ethan Feldman

JW Player Support Agent  
0 rated :

Hi Matt,

This is Ethan from LongTail here to help you.

Can you link me to where you are running our player on your site so I can take a look at your implementation so I can better help you?

Please email me directly at ethan [at] longtailvideo [dot] com to follow up if you have any other questions, thank you.

Best Regards,
-Ethan

JW Player

User  
0 rated :

i too have a same problem pleasa give a solution
thank you

Ethan Feldman

JW Player Support Agent  
0 rated :

@chet – thank you!

JW Player

User  
-1 rated :

issue with yt

http://developer.longtailvideo.com/trac/ticket/201

JW Player

User  
1 rated :

Solution is here

http://www.longtailvideo.com/support/forum/Bug-Reports/21578/Solved-bug-volume-settings-in-IE-with-youtube

This question has received the maximum number of answers.